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Installation Guide Overview  

The ProblemTracker Installation Guide provides the details necessary to prepare for and install your 
ProblemTracker software. Information such as system requirements, license information, and 
recommendations for web server and browser settings are included in this guide. 

Additional Help Guides 

After installing ProblemTracker, you can begin to configure your workgroups (databases) with the information 
available in the Workgroup Management System Guide. 

The Administration Guide is available to help you customize each of your ProblemTracker workgroups 
(databases). 

Lastly, a User's Guide is available as a resource for your ProblemTracker users. 
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Installation Guide Glossary  

Glossary of Terms

Click on the term to read more about it within the Help section listed to the right. 

●      Enter Key 
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- Entering License Information 
●      Remove Key 
- Entering License Information 
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System Requirements  

Client Requirements

●     Any platform on which Netscape Navigator/Communicator version 4.07 or greater, Netscape version 6.2 
or greater, or Microsoft Internet Explorer version 5.0 or greater is available. 

●     Netscape Navigator/Communicator version 4.07 or greater, Netscape version 6.2 or greater (6.0/6.1 not 
supported), or Microsoft Internet Explorer version 5.0 or greater. 

●     If you are using a non-Latin1 language, then the browser requirement is Internet Explorer 5.0 or greater 
or Netscape 6.2 or greater. The platform requirement is any platform on which Internet Explorer 5.0 or 
greater or Netscape 6.2 or greater are supported. Latin1 languages include the following - Basque, 
Catalan, Danish, Dutch, English, Finnish, French, German, Icelandic, Italian, Norwegian, Portuguese, 
Spanish, and Swedish. 

Server Requirements

●     450 MHz Intel Pentium III or compatible system (866 MHz Pentium III or faster recommended). 
●     128 MB RAM for Windows NT, 192 MB RAM for Windows 2000 (256 MB recommended for Windows 

NT, 512 MB recommended for Windows 2000). 
●     4 GB Hard Drive (ProblemTracker uses approximately 10 MB of hard disk space for each workgroup). 
●     Windows NT 4.0 Workstation or Server, Windows XP Professional or Windows 2000 Server (Windows 

2000 Server recommended, Windows 2000 Server required if using a non-Latin1 language). Windows 
XP Professional is only recommended for use with ProblemTracker for evaluation purposes because it 
is not a "server" platform. Windows XP Professional is not supported for use with an Oracle 8i or 9i 
database. 

●     Microsoft Internet Information Server 4.0 or 5.0 (IIS 5.0 recommended, IIS 5.0 required if using a non-
Latin1 language). 

●     MDAC 2.5 or greater. This is included in Windows 2000 and can be downloaded for Windows NT 4.0. 
●     Microsoft JET 4.0 Service Pack 5 or greater. This is included in Windows 2000 Service Pack 2 and can 

be downloaded for Windows NT 4.0 and earlier versions of Windows 2000. 
●     JScript 5.1 or greater is required. This is included in Windows 2000 and Internet Explorer 5.5 or greater. 

It can also be downloaded and installed separately. 
●     In order to integrate Source Code Control with ProblemTracker, Microsoft Visual SourceSafe Version 

6.0 Server with Service Pack 5 is required. 

Details about how to verify that you have the proper components installed and where to download them if you 
do not can be found in the Preparation for Installing ProblemTracker section. 

Optional Database Support

In addition to the included support for Microsoft Access, ProblemTracker can be used with the following 
database systems 
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●     Microsoft SQL Server 7.0 and 2000 
●     Oracle 8i 
●     Oracle 9i 

For Further Information

For further information on NetResults ProblemTracker, please browse to our web site at 
www.problemtracker.com. There you can find the latest product, ordering, and support information. 
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Preparation for Installing ProblemTracker  

Overview

ProblemTracker requires that a supported web server, database drivers, and (optionally) SQL Server or Oracle 
software is installed prior to running the ProblemTracker Setup (installation) program. Most or all of this 
software may already be installed. The sections below describe what is required, how to verify that the 
appropriate software is installed, and how to download and install the software, if necessary. 

Web Server Software

Microsoft Internet Information Server (IIS) version 4.0 or 5.0 and Microsoft NT 4.0 Personal Web Server (also 
known as IIS 4.0 when installed on NT 4.0 Workstation) are supported for use with ProblemTracker. If you are 
using IIS on Windows NT, you may need to install an update to your Windows Script (JScript) software (see 
below). This update is not required if you are using Windows 2000. 

IIS 5.0 on Windows 2000 Server
Microsoft Internet Information Server 5.0 is probably already installed on your Windows 2000 Server machine. 
If installed, the following item should be in your start menu.
Start->Programs->Administrative Tools->Internet Services Manager
 
If the web server is not installed, you can add it using Add/Remove Programs in the Control Panel. After 
starting Add/Remove programs, click on the Add/Remove Windows Components box, then check Internet 
Information Services (IIS) in the wizard display that appears. If you would like to install the minimum necessary 
components, select Internet Information Services and click Details. Then select Common, Internet Information 
Services Snap-In (a tool used to configure your web server) and World Wide Web Server (the web server) and 
click OK (you do not need "Internet Services Manager (HTML)"). Then click Next to install IIS 5.0. 

If you are planning to use multinational workgroups (UTF-8 character set for support of languages other than 
western European), you must have the Q294831 IIS 5.0 hot fix installed. If you have installed Windows 2000 
Service Pack 3, then this hot fix is already on your server. Otherwise (if you are using SP2 or earlier), please 
browse to the IIS 5.0 UTF-8 Encode Hot Fix page, download, and install the hot fix. This hot fix does not apply 
to IIS 4.0 (as IIS 4.0 does not support UTF-8). 

IIS 4.0 on Windows NT 4.0
Microsoft Internet Information Server 4.0 (NT 4.0 Server) or the NT 4.0 Personal Web Server (NT 4.0 
Workstation) may already be installed on your machine. If installed, the following item should be in your start 
menu.
Start->Programs->Windows NT 4.0 Option Pack->Internet Information Server
(if using NT 4.0 Server) or
Start->Programs->Windows NT 4.0 Option Pack->Personal Web Server
(if using NT 4.0 Workstation).
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If the web server is not installed, it is included in the Windows NT 4.0 Option Pack available directly from 
Microsoft. Please follow the instructions provided with the Windows NT 4.0 Option Pack to install the web 
server. When installing the Option Pack, please make sure the "Internet Service Manager" and "World Wide 
Web Server" components are installed. These components are set to install if the default installation 
parameters are accepted. After installing, please reinstall the NT 4.0 Service Pack which you are using to apply 
the latest IIS fixes to your Option Pack installation. NT 4.0 Service Pack 6a (or greater) is required for use with 
ProblemTracker. 

As ProblemTracker requires JScript 5.1 or greater, you may also need to install the Windows Script 5.1 (or 
greater) engine. If you have already installed Internet Explorer 5.5 (or greater) on your web server machine, 
you already have Windows Script 5.5 (or greater) installed. Otherwise, please install/upgrade to Internet 
Explorer 5.5 (or greater) or do the following. Browse to the Windows Script Download page. We recommend 
that you download version 5.5 (and the rest of this paragraph assumes version 5.5). If you are using US 
English as your locale, scroll to the bottom and click on the scr55en.exe (US English NT 4.0 version) to 
download the self-extracting .exe file. If you are using another language, click on the appropriate language on 
the left, scroll down to the bottom and click scr55*.exe to download. To install, double-click the .exe file from 
Windows Explorer. 

Database Driver Software on Web Server Machine

ProblemTracker requires Microsoft Data Access Components (MDAC) 2.5 or greater, JET 4.0 Service Pack 5 
(JET 4.0 SP5) or greater, and, if you are using Oracle 8i or 9i as your database, the Oracle 8i or 9i client drivers 
installed on the web server machine on which you are going to install ProblemTracker. 

MDAC 2.5
If you are using Windows 2000, then MDAC 2.5 or greater is already installed. Otherwise, you should check the 
MDAC version on your machine by running regedit (Start->Run..., enter regedit.exe) and check the 
"FullInstallVer" value under the key HKEY_LOCAL_MACHINE\Software\Microsoft\DataAccess. It should be 
2.50.x or greater. If it is not, then you should download and install MDAC 2.5 or greater (we recommend MDAC 
2.5 Service Pack 2) from the Microsoft Universal Data Access page. 

JET 4.0 Service Pack 5 or Greater
If you have installed Windows 2000 Service Pack 2 (SP2), then you already have JET 4.0 Service Pack 5 
installed. You can also verify whether or not you have JET 4.0 SP5, by finding the file msjetoledb40.dll (typically 
in C:\Windows\System32) in Windows Explorer, right-clicking on the file, selecting Properties, clicking on the 
Version tab and verifying that the File Version is 4.00.4331.4 or greater. If you do not have JET 4.0 SP5 (or 
greater) or are not sure you have it, you should download and install JET SP5 from the JET 4.0 SP5 Download 
page. After installing the JET service pack, please be sure to reboot your machine before attempting to install 
ProblemTracker. 

Oracle 8i or 9i
If you are using Oracle 8i or 9i as your database for ProblemTracker and you do not have your Oracle 8i or 9i 
server installed on the same machine as the web server you intend to use for ProblemTracker, then you need 
to install the Oracle 8i or 9i Client for Microsoft Windows on the web server machine. You should install either 
Oracle8i Client Release 2 (8.1.6), Oracle8i Client Release 3 (8.1.7), or Oracle 9i. However, you can still 
connect to a Oracle8i Release 1 (8.1.5) database server with Oracle 8i Client Release 2 or 3 installed. On the 
client (web server) we use the Oracle OLEDB driver which was not available in Oracle8i Client Release 1 
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(8.1.5). 

Database Server Software

If you plan to use Microsoft Access as your database, you don't need to install any software. The Access 
drivers that ProblemTracker uses are included with MDAC, so you have completed preparation for installing 
ProblemTracker. For information on maintenance of your Access database(s), please review the Database 
Administration section of this Help document. 

SQL Server 7.0 and 2000
If you plan to use Microsoft SQL Server as your database, you need to install this prior to installing 
ProblemTracker. It should either be installed on the web server machine which you plan to use for 
ProblemTracker or on a machine that can be accessed over the network from the web server machine (via 
TCP/IP). It is generally easier to configure if it is installed on the web server machine (no possible firewall or 
network issues); however, a remote database may have better performance (because it won't use resources on 
your web server machine, although, that must be weighed against network delays in communicating with the 
database server machine). After you install SQL Server and prior to installing ProblemTracker, you must 
configure it to use SQL Server Authentication. This type of authentication is used by ProblemTracker when 
communicating with SQL Server. Instructions on how to do this are below. 

1.  Start the Microsoft SQL Server Enterprise Manager. 
2.  Expand the tree in the left pane until you find the database server you wish to use (its name is usually 

the name of the machine on which it is running). 
3.  Right click on the server entry in the left pane and select "Properties...". 
4.  Click on the "Security" tab. 
5.  Select "SQL Server And Windows NT". 
6.  Click on OK. 

Oracle 8i or 9i
If you plan to use Oracle as your database, you need to install this prior to installing ProblemTracker. It should 
either be installed on the web server machine which you plan to use for ProblemTracker or on a machine that 
can be accessed over the network from the web server machine (via TCP/IP). It is generally easier to configure 
if it is installed on the web server machine (no possible firewall or network issues, no need to update the client 
configuration with each new database name); however, a remote database may have better performance 
(because it won't use resources on your web server machine, although, that must be weighed against network 
delays in communicating with the database server machine). Currently Oracle 8i Database Release 1, 2, and 3 
(8.1.5, 8.1.6, and 8.1.7) or Oracle 9i are supported as the server. However, you must use at least Oracle 8i 
Release 2 if your database server is on the same machine as ProblemTracker (as ProblemTracker requires 
client drivers from Oracle 8i Release 2 or greater). 

SQL Server and Oracle
After you have installed ProblemTracker, please schedule regular SQL Server or Oracle backups of 
your ProblemTracker database(s). Unlike a standard windows application (or Microsoft Access 
database file), SQL Server and Oracle database files are not standard files and can not be backed up by 
a simple file copy or simple file backup to tape. If you do not schedule backups via SQL Server, Oracle or 
via backup software that connects with SQL Server / Oracle to perform a backup, you will not be able to restore 
your data in the event of a hard disk failure or other hardware/software failure. Please consult your SQL Server 
/ Oracle manuals for directions on how to backup your database. Please review the Database Administration 
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section of this Help document for details on the name(s) of the ProblemTracker database(s). If you are 
uncomfortable with these procedures we would strongly recommend that you use Microsoft Access as your 
database. A simple file backup will work and, while a lot of factors can affect performance, if you are using a 
server with our recommended hardware configuration, an Access database should be able to handle five 
thousand problem records per ProblemTracker workgroup (perhaps more if you have a newer server). 

Anti-Virus Software

Temporarily disable any anti-virus software while you run the installation program and perform configuration 
steps in the Workgroup Management System (WMS). This is recommended so that your anti-virus software will 
not prevent the installation program or WMS from performing operations such as copying files, running scripts, 
configuring your web server, setting file permissions and registry entries. Your anti-virus software can be 
reactivated safely after you have completed the installation steps and any necessary WMS configuration. 
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Installing ProblemTracker  

Installing ProblemTracker Software

To install ProblemTracker software, please follow the instructions on our web site or those included with your 
license or evaluation email. Temporarily disable any anti-virus software while you run the installation program 
and perform configuration steps in the Workgroup Management System (WMS). This is recommended so that 
your anti-virus software will not prevent the installation program or WMS from performing operations such as 
copying files, running scripts, configuring your web server, setting file permissions and registry entries. Your 
anti-virus software can be reactivated safely after you have completed the installation steps and any necessary 
WMS configuration. To install ProblemTracker, login as Administrator on the web server machine on which you 
would like to install ProblemTracker and run the self-extracting .exe file you downloaded or the setup.exe 
program on the CD you received. During the installation, you will be asked to select a time zone. For a list of 
available time zones in your operating system, please refer to one of the following sections: 
Windows 2000 and Windows XP Time Zones 
Windows NT 4.0 Time Zones 
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Entering License Information  

If you are starting a trial of ProblemTracker, you can skip this section. A license key does not need to be 
entered at this time. 

Entering License Information

When you purchase a license for ProblemTracker, you will receive a license key (or multiple keys depending on 
the type of licenses and options you have purchased) that enables the product beyond the trial period. To enter 
this key, run the ProblemTracker License Manager program that was installed with ProblemTracker. You 
should be able to run this program from the Start button following this menu: 

Start->Programs->NetResults ProblemTracker->ProblemTracker License Manager
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The "General" tab of the License Manager contains the product (ProblemTracker or ProblemTracker Enterprise 
Edition), your trial status (how many days remain in your trial period), and a summary of the license keys you 
have entered and features that are enabled. 

There are 4 different license key types: 

●     Static (Named User) 
●     Floating (Concurrent User) 
●     Alerts (Enterprise Edition Only) 
●     Discussion (Enterprise Edition Only) 

Each key type has its own tab in the License Manager. When entering each license key, be sure to fill out all 
fields in the section, then press the "Enter Key" button after entering the information. 

Each software key is matched to a particular email address (also provided when the product is ordered) so it is 
important that both the email address and key be entered exactly as given in the email containing your license 
information (case does matter). And, the email address associated with a license key can only be changed 
when you purchase additional licenses of the same type (static or floating). 
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If you have purchased only floating licenses, then after entering your license information (in the "Floating" tab of 
the License Manager), you should log in to ProblemTracker as Admin in order to convert your existing trial 
accounts (which are static license accounts by default) to floating. The first time you attempt to login to 
ProblemTracker as Admin after entering your license key, you will be asked whether all of your users should be 
converted to the floating license type. Please click on the Yes button so that all of your users will be converted 
to the floating license type. Once they are converted by this step, your users will be able to login to 
ProblemTracker. 

The Admin user account is considered a static account for login purposes (the Admin user can always login). 
However, it is not counted when enforcing license limits (users with only floating licenses can, of course, still 
use the Admin account, and the Admin user account does not count against the number of static licenses). In 
other words, the Admin user account is a special system account that is available for use in administering 
ProblemTracker as long as you have purchased at least one license. Likewise, the TBD "user" (which 
represents "no one") and the INET "user" (which represents records reported through via the Customer Bug 
Page) are also not counted against the licensing limits (and, no one can actually log in as TBD or INET). 

See the License Administration section of the Workgroup Management System for further information on 
configuration of user accounts. 

To remove a license key, click on the Remove Key and click "Yes" to confirm the operation. 

To replace a license key, click on the Remove Key and click "Yes" to confirm the operation. Enter the new 
license key information, then click on the Enter Key button. 

After entering a license key for Alerts and / or Discussion features, please go to the General Preferences 
section to enable the Alerts and / or Discussion features in your workgroup(s). 

License Agreement

The ProblemTracker (or ProblemTracker Enterprise Edition) License Agreement can be found in the License 
Manager by clicking on the "License Agreement..." button at the bottom of the "General" tab or the "About" tab. 
Please review this for the specific terms and conditions of your license(s). 
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Creating a Workgroup  

After completing the installation process, the next step is to create a workgroup(s) . If you chose to install the 
default workgroup during the installation set up program, you can begin using this workgroup immediately. To 
login to the default workgroup, you can browse to: 

http://servername/pteval/ptlogin.asp 

where servername is the TCP/IP name of the machine where ProblemTracker is installed. Alternatively, you 
can get to this default workgroup from the machine where ProblemTracker is installed by going to Start -> 
Programs -> NetResults ProblemTracker 4 -> ProblemTracker Eval Version -> Login Page 

If you wish to create an alias for this default workgroup, please refer to the Managing Aliases section of the 
Workgroup Management System Guide. 

To create a new workgroup(s), please refer to the Adding a Workgroup section of the Workgroup Management 
System Guide. 
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Browser Settings  

ProblemTracker does not require any special plugins or unusual browser configuration. So, by default, almost 
all browsers are already configured for use with ProblemTracker. However, if support for cookies or JavaScript 
have been disabled in your browser configuration, then you may need to modify the settings. Information on 
that is below. If such support has not been disabled, you can skip to the next section. 

Brower Settings

ProblemTracker uses browser cookies to maintain its state during a session. And, it uses JavaScript to provide 
data validation on the client side (which improves overall system performance). In order to use ProblemTracker, 
you must enable the setting of cookies and use of JavaScript in your browser. 

By default, most browsers have cookies enabled. However, you can use the table below to determine where to 
verify that cookies are enabled on your browser. 

Beginning in IE 6, there are multiple levels for enabling cookies. It is recommended that the default option, 
Medium, is selected. 

Browser Menu

Netscape 4 Edit->Preferences->Advanced->Cookies 
Netscape 6.2 Edit->Preferences->Privacy & Security->Cookies 

IE 5 Tools->Internet Options->Security->Custom Level->Cookies 
IE 6 Tools->Internet Options->Security->Privacy (select Medium) 

By default, most browsers have JavaScript enabled. However, you can use the table below to determine where 
to verify that JavaScript is enabled on your browser. 

Browser Menu

Netscape 4 Edit->Preferences->Advanced->Enable JavaScript 
Netscape 6.2 Edit->Preferences->Advanced->Enable JavaScript 

IE 5 Tools->Internet Options->Security->Custom Level->Scripting->Active Scripting 
IE 6 Tools->Internet Options->Security->Custom Level->Scripting->Active Scripting 
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Program URLs  

Overview

ProblemTracker is a web application and is accessed by using a standard web browser. Once correctly 
installed on a web server by the ProblemTracker Administrator, you access ProblemTracker by entering the 
appropriate URL into your browser. 

Starting ProblemTracker

Once installed, ProblemTracker can be accessed via the following URL: 

http://serverName/workgroup/ptlogin.asp 

where serverName is the TCP/IP name of the host where the ProblemTracker server software is installed, and 
workgroup is the name of the ProblemTracker workgroup. 

For example, if you installed the default workgroup on a server named MyServer , you would use this URL: 

http://MyServer/pteval/ptlogin.asp 

Optionally, you can browse to any ProblemTracker workgroup by omitting the "ptlogin.asp" from the URL above 
as that is configured as the default page for each workgroup. 

This will present the ProblemTracker login screen where you can enter your User ID and Password. If this is 
your first time using ProblemTracker, please see your Administrator for your User ID and Password. If you are 
the Administrator and this is your first time using ProblemTracker, please login using Admin as the User ID and 
Admin as the Password. Then, please change the Password. 
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Web Server Security Overview  

If you do not wish to configure web server security (perhaps your web server is on an internal machine behind a 
"firewall"), you have completed ProblemTracker installation and configuration. You can now login to 
ProblemTracker or proceed to the ProblemTracker tutorial. 

ProblemTracker Security

ProblemTracker supports security at two levels. The product includes a flexible user group based security 
scheme, allowing control of access to both function (Add, Edit, View, etc.) and data records. In addition, 
ProblemTracker also supports the use of your web server's native security mechanism to limit access to the 
web pages themselves. If you have very strict security requirements, you may wish to apply web server security 
to your ProblemTracker installation. 

Web Server Security

Many web servers allow you to restrict access to a web site on a per user basis via a process called basic 
authentication. ProblemTracker has been designed with this in mind, allowing you to limit access to any 
function by using the web server's built-in security mechanism. 

ProblemTracker Organization

The ProblemTracker web pages are organized by function as shown in the following table. In general all pages 
related to a particular function have been included in the same directory, using a common program file. By 
applying security to these directories and program files as desired, you can limit each individual or group in 
your organization to the functions appropriate to their job. When a user browses to a page or program where 
security has been applied, a dialog appears in their browser requiring them to enter a username and password. 
Depending upon their identity, they will be allowed or denied access to the resource. 

Note that the following table assumes that a workgroup named pteval, the Evaluation Workgroup, has been 
installed. For your workgroup, substitute your workgroup name where "pteval" appears. rootDir is the web 
server root directory where the ProblemTracker content and program files were installed (by default, 
C:\Inetpub\wwwroot\ProblemTracker). 
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Function Directory

Workgroup Management System Administrative 
Functions 

rootDir/ptadmin
rootDir/ptcgiadmin
rootDir/ptcommon
rootDir/pttemplate
rootDir/pttmp

Workgroup Administrative Functions 
rootDir/pteval/Admin
rootDir/pteval/Importer
rootDir/pteval/Include

Normal Internal User Operations rootDir/pteval/Intranet 

External User Operations rootDir/pteval/Internet 

Add Record rootDir/pteval/Intranet/Add 

Edit Record rootDir/pteval/Intranet/Edit 

View Record rootDir/pteval/Intranet/View 

Advance Record State rootDir/pteval/Intranet/Task 

Delete Record rootDir/pteval/Intranet/Delete 

File Attachments rootDir/pteval/Attachments 

Generate Report rootDir/pteval/Intranet/Report 

Discussion - Enterprise Edition Only rootDir/pteval/Intranet/Discuss 

Documentation rootDir/pteval/Help 

Workgroup Management Sysytem Admin 
Documentation rootDir/ptadmin/Help

Workgroup Admin Documentation rootDir/pteval/Help/Admin

User Documentation rootDir/pteval/Help/std 

Setting Web Server Security

The procedure for configuring web server security varies for each web server product. This document provides 
general instructions for setting up security as it relates to ProblemTracker for the following web servers. 
However, you should also consult the documentation provided with your web server for details regarding its 
security options. 

●     Microsoft IIS 4.0 & NT 4.0 Personal Web Server (Windows NT 4.0) 
●     Microsoft IIS 5.0 (Windows 2000 Server) 
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WMS Operations that can impact your Custom Security Settings

The Repair, Move, and Upgrade operations that can be performed in the Workgroup Management System can 
reset the customized security you have applied to the locations listed in the table above. Before you use the 
Repair, Move, or Upgrade operations, it is recommended that you take note of the security scheme you have 
applied, then re-apply these changes after using one of those operations. 

For more information on the WMS operations, please refer to the following sections in the WMS Help Guide: 

Repairing a Workgroup
Moving a Workgroup
Upgrading a Version 3 Workgroup
Upgrading a Version 4 or 5 Workgroup 
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Applying Security Using IIS 4.0 & NT Personal 
Web Server 

 

Overview

Internet Information Server 4.0 & NT Personal Web Server use the native security features of the NTFS file 
system and Windows NT user administration to provide security for web pages. In order to password protect 
ProblemTracker on any of these web servers you must install it on an NTFS file system. 

Instructions

The following instructions assume a workgroup named pteval is installed. For your workgroup, substitute your 
workgroup name for "pteval" in the steps below. 

1.  Enable Authentication 
❍     Start the Internet Service Manager 

NT Workstation
Start->Programs->Windows NT 4.0 Option Pack->Microsoft Personal Web Server->Internet 
Service Manager 

NT Server
Start->Programs->Windows NT 4.0 Option Pack->Microsoft Internet Information Server-
>Internet Service Manager 

❍     Select Default Web Site or a Web Site of your choice 
❍     Double click on the content directory folder (pteval) in the left window pane. The files included in 

the pteval folders are displayed in the right window pane. 
❍     For each file or folder that you would like to password protect, repeat the following steps: 

■     Right click on the file or directory. A pull down menu appears. Select Properties. 
■     Select the File Security (or Directory Security) tab. 
■     Press the Edit... button in the Anonymous Access and Authentication Control. 
■     Unselect Allow Anonymous Access. 
■     Select Basic Authentication. A warning dialog box will pop up. Press Yes. Press the 

Edit... button for Basic Authentication. 
■     An input dialog for Basic Authentication Domain will pop up. Select the appropriate 

domain for your Web Server. In most cases it should be the local domain. If so, select 
Use Default and press OK. 

■     Press OK in the Authentication Method dialog box. 
■     Press Apply and then OK in the Properties dialog box. 

2.  Set File Security on Windows NT 
❍     Start the Windows NT Explorer 
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❍     Select the directory where ProblemTracker is installed, e.g. pteval. 
❍     In the right pane of the Explorer, select the directory or file(s) you would like to limit access to. 

You can select multiple items by holding down the Control key as you click on files. 
❍     With the files highlighted, select the "File->Properties" menu, click on the Security tab of the 

dialog, and press the Permissions button. 
❍     The File Permissions dialog is displayed. By default it has the value "PUSR4<HOSTNAME> 

Modify" where <HOSTNAME> is the TCP/IP name of the machine where ProblemTracker is 
installed. Delete this row, and any others that grant access to anyone you do not wish to have 
access to the selected directory or files. If you do not wish for an individual to see a web page, 
make sure the user does not have Read (R) permissions for the file or directory. 

❍     Press the Add... button to display the Add Users and Groups dialog. Under "List Names From:" 
select your Windows NT domain and click on the Show Users button. Now add any particular 
user you would like to give access to the select directory or files by selecting their name, 
pressing the "Add" button, selecting the access type, and pressing OK. Repeat this process for 
any other users. 

❍     Back on the File Permissions dialog, press the Add... button to display the Add Users and 
Groups dialog. Under "List Names From:" select your machine (\\HostName*, where HostName 
is the name of your machine), and click on the Show Users button. Now add any users you 
defined earlier (e.g. Administrator) by selecting the name, pressing the "Add" button, selecting 
the appropriate access and pressing OK. 

❍     Press the OK button, and the OK button again. 
❍     Refer to the table in the Web Server Security Overview section to determine which content 

directories and program files you would like to protect based upon function. Then repeat the 
process described here for each. 

WMS Operations that can impact your Custom Security Settings

The Repair, Move, and Upgrade operations that can be performed in the Workgroup Management 
System can reset the customized security you have applied to the locations listed in the table above. 
Before you use the Repair, Move, or Upgrade operations, it is recommended that you take note of the 
security scheme you have applied, then re-apply these changes after using one of those operations. 

For more information on the WMS operations, please refer to the following sections in the WMS Help 
Guide: 

Repairing a Workgroup
Moving a Workgroup
Upgrading a Version 3 Workgroup
Upgrading a Version 4 or 5 Workgroup 
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Applying Security Using IIS 5.0 (Windows 2000 
Server) 

 

Overview

Microsoft Internet Information Services (IIS) 5.0 bundled with Microsoft Windows 2000 Server uses Active 
Directory, ADSI, and Directory Services to set/read permissions to provide security for the web pages. IIS 5.0 
uses the native security features of the NTFS file system and Active Directory Users and Computers (or 
Computer Management Console) to provide security for web pages. In order to password protect 
ProblemTracker on this web server you must install it on an NTFS file system. Microsoft Windows 2000 
provides tightly integrated and flexible security. Thus the security permissions on the Windows 2000 directories 
are very restrictive by default. 

Instructions

The following instructions assume a workgroup named ptdev is installed. For your workgroup, substitute your 
workgroup name for "ptdev" in the steps below. 

1.  Enable Password Protection 
❍     Start the Internet Services Manager ( Start->Programs->Administrative Tools-

>Internet Services Manager ) 
❍     Double click on the computer/domain name under the folder "Internet Information Services" 
❍     Select the Default Web Site or a Web Site in which the ProblemTracker virtual directories (e.g. 

ptdev) are created. 
❍     Double click on the content directory folder (ptdev) in the left window pane. The files included in 

the ptdev folders are displayed in the right window pane. 
❍     For each file or folder that you would like to password protect, repeat the following steps: 

■     Right click on the file or directory. A pull down menu appears. Select Properties. 
■     Select the File Security (or Directory Security) tab. 
■     Press the Edit... button in the Anonymous Access and Authentication Control. 
■     Unselect Allow Anonymous Access. 
■     Select Basic Authentication. A warning dialog box will pop up. Press Yes. Press the 

Edit... button for Basic Authentication. 
■     An input dialog for Basic Authentication Domain will pop up. Select the appropriate 

domain for your web Server. In most cases it should be the local domain. If so, select 
Use Default and press OK. 

■     Press Ok in the Authentication Method dialog box. 
■     Press Apply and then OK in the Properties dialog box. 

2.  Set File/Directory Security on Windows 2000 Server 
❍     Start the Windows 2000 Explorer ( Start->Programs->Accessories->Windows Explorer ) 
❍     Select the directory where ProblemTracker is installed, e.g. ptdev. 
❍     In the right pane of the Explorer, select the directory or file(s) you would like to limit access to. 

You can select multiple items by holding down the Control key as you click on files. 
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❍     With the files or the directory highlighted, select the "File->Properties" menu or right click and 
choose Properties menu, and click on the Security tab of the dialog. 

❍     By default "PUSR4<HOSTNAME>" where <HOSTNAME> is the TCP/IP name of the server 
where ProblemTracker is installed will have all the check boxes checked (and grayed) under the 
column "Allow" and none checked under the column "Deny". 

❍     Delete the default permission for "PUSR4<HOSTNAME>" and any others that grant access to 
anyone you do not wish to have access to the selected directory or files, by selecting those 
users and clicking the "Remove" button. If you do not wish for an individual to see a web page, 
make sure the user does not have Read checkbox checked under the column "Allow" (or if the 
Read checkbox is checked and grayed then check the Read checkbox under the column 
"Deny") for the file or directory. 

❍     Press the "Add..." button to display the "Select Users, Computers and Groups" dialog. Under 
"Look In:" select your Windows 2000 domain name. Now add any particular user/group (for 
example "Administrator" you would like to give access the selected directory or files by selecting 
their names (press Ctrl to select multiple users/groups), and pressing the "Add" button. The 
users/groups will be listed in the list below. Now click "OK" to close this dialog. The users/groups 
chosen will get added to the list. You can grant/deny permissions for each user/group by 
checking/unchecking the checkboxes under the columns "Allow" and "Deny". 

❍     Refer to the table in the Web Server Security Overview section to determine which content 
directories and program files you would like to protect based upon function. Then repeat the 
process described here for each of the directory. 

WMS Operations that can impact your Custom Security Settings

The Repair, Move, and Upgrade operations that can be performed in the Workgroup Management 
System can reset the customized security you have applied to the locations listed in the table above. 
Before you use the Repair, Move, or Upgrade operations, it is recommended that you take note of the 
security scheme you have applied, then re-apply these changes after using one of those operations. 

For more information on the WMS operations, please refer to the following sections in the WMS Help 
Guide: 

Repairing a Workgroup
Moving a Workgroup
Upgrading a Version 3 Workgroup
Upgrading a Version 4 or 5 Workgroup 
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Uninstalling ProblemTracker  

ProblemTracker fully supports Windows uninstall, and can be removed from the web server by using the icon 
labeled "Repair-Uninstall ProblemTracker" that is located in the ProblemTracker Program folder, or by using the 
"Add/Remove Programs" icon in the Control panel. This operation must be done while logged in as 
Administrator (or a user in the Administrators group) on the web server machine on which ProblemTracker is 
installed. After starting the Setup program from the ProblemTracker Program folder or Add/Remove Programs, 
click Next on the welcome dialog. Then select Remove and on the next dialog and click Next. You can also 
select Repair on this dialog to reinstall the ProblemTracker files, if you feel some of those files have been 
accidentally modified or removed. 

If you were using the Alerts feature, after uninstalling ProblemTracker you must manually delete the Scheduled 
Task created for the Alerts function. To do this, 

1.  Go to Start->Settings->Control Panel 
2.  Double click on Scheduled Tasks 
3.  Right click on the Scheduled Task used for ProblemTracker Alerts 
4.  Select Delete 
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Windows 2000 / XP Time Zone Selection Chart  

The following is a list of time zones that are supported by ProblemTracker when installed on a Windows 2000 
(or Windows XP) system. Entries with (*) are only available in Windows XP. 

Time Zone 
Offset (in 
Hours)

Time Zone
System Time Zone (as 
displayed in Date/Time 
Settings)

-12:00 Dateline Standard Time Eniwetok, Kwajalein

-11:00 Samoa Standard Time Midway Is, Samoa

-10:00 Hawaiian Standard Time Hawaii

-10:00 Alaskan Standard Time Alaska

-08:00 Pacific Standard Time
Pacific Time (US & 
Canada); Tijuana

-07:00
Mexican Standard Time[La 
Paz](*)

Chihuahua, La Paz, 
Mazatlan

-07:00 Mountain Standard Time
Mountain Time (US & 
Canada)

-07:00
Mountain Standard Time 
[Arizona]

Arizona

-06:00 Central Standard Time
Central Time (US & 
Canada)

-06:00 Mexico Standard Time Mexico City, Tegucigalpa

-06:00
Canada Central Standard 
Time

Saskatchewan

-06:00
Central America Standard 
Time

Central America

-05:00 Eastern Standard Time
Eastern Time (US & 
Canada)

-05:00
Eastern Standard Time 
[Indiana (East)]

Indiana (East)
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-05:00 SA Pacific Standard Time Bogota, Lima, Quito

-04:00 Atlantic Standard Time Atlantic Time (Canada)

-04:00 SA Western Standard Time Caracas, La Paz

-04:00 Pacific SA Standard Time Santiago

-03:30
Newfoundland Standard 
Time

Newfoundland

-03:00 SA Eastern Standard Time Buenos Aires, Georgetown

-03:00
E. South America Standard 
Time

Brasilia

-03:00 Greenland Standard Time Greenland

-02:00 Mid-Atlantic Standard Time Mid-Atlantic

-01:00 Azores Standard Time Azores

-01:00 Cape Verde Standard Time Cape Verde Is

00:00 Universal Coordinated Time Casablanca, Monrovia

00:00 Greenwich Mean Time
Greenwich Mean Time: 
Dublin, Edinburgh, Lisbon, 
London

+01:00 Romance Standard Time
Amsterdam, CopenHagen, 
Madrid, Paris, Vilnius

+01:00
W. Central Africa Standard 
Time

West Central Africa

+01:00
Central European Standard 
Time

Belgrade, Sarajevo, Skopje, 
Sofija, Zagreb

+01:00
Central Europe Standard 
Time

Bratislava, Budapest, 
Ljubljana, Prague, Warsaw

+01:00 W. Europe Standard Time
Brussels, Berlin, Bern, 
Rome, Stockholm, Vienna

+02:00 Egypt Standard Time Cairo

+02:00 South Africa Standard Time Harare, Pretoria

+02:00 Israel Standard Time Israel
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+02:00 E. Europe Standard Time Bucharest

+02:00 FLE Standard Time Helsinki, Riga, Tallinn

+02:00 GTB Standard Time Athens, Istanbul, Minsk

+03:00 Arab Standard Time Kuwait, Riyadh

+03:00 E. Africa Standard Time Nairobi

+03:00 Arabic Standard Time Baghdad

+03:00 Russian Standard Time
Moscow, St. Petersburg, 
Volgograd

+03:30 Iran Standard Time Tehran

+04:00 Arabian Standard Time Abu Dhabi, Muscat

+04:00 Caucasus Standard Time Baku, Tbilisi

+04:00 Afghanistan Standard Time Kabul

+05:00 West Asia Standard Time
Islamabad, Karachi, 
Tashkent

+05:00 Ekaterinburg Standard Time Ekaterinburg

+05:30 India Standard Time
Bombay, Calcutta, Madras, 
New Delhi

+05:45 Nepal Standard Time Kathmandu

+06:00 Central Asia Standard Time Almaty, Dhaka

+06:00 Sri Lanka Standard Time Columbo

+06:00
N. Central Asia Standard 
Time

Almaty, Novosibirsk

+06:30 Myanmar Standard Time Rangoon

+07:00 SE Asia Standard Time Bangkok, Hanoi, Jakarta

+07:00 North Asia Standard Time Krasnoyarsk

+08:00 China Standard Time
Beijing, Chongqing, Hong 
Kong, Urumqi

+08:00 W. Australia Standard Time Perth

+08:00 Singapore Standard Time Singapore
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+08:00 Taipei Standard Time Taipei

+08:00
North Asia East Standard 
Time

Irkutsk, Ulaan Bataar

+09:00 Tokyo Standard Time Osako, Sapporo, Tokyo

+09:00 Korea Standard Time Seoul

+09:00 Yakutsk Standard Time Yakutsk

+09:30 AUS Central Standard Time Darwin

+09:30
Cen. Australia Standard 
Time

Adelaide

+10:00 AUS Eastern Standard Time
Canberra, Melbourne, 
Sydney

+10:00 E. Australia Standard Time Brisbane

+10:00 West Pacific Standard Time Guam, Port Moresby

+10:00 Tasmania Standard Time Hobart

+10:00 Vladivostok Standard Time Vladivostok

+11:00
Central Pacific Standard 
Time

Magadan, Solomon Is, New 
Caledonia

+12:00 Fiji Standard Time Fiji, Kamchatka, Marshall Is

+12:00 New Zealand Standard Time Auckland, Wellington

+13:00 Tonga Standard Time Nuku'alofa
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Windows NT 4.0 Time Zone Selection Chart  

The following is a list of time zones that are supported by ProblemTracker when installed on a Windows NT 4.0 
system. 

Time Zone 
Offset (in 
Hours)

Time Zone
System Time Zone (as 
displayed in Date/Time 
Settings)

-12:00 Dateline Standard Time Eniwetok, Kwajalein

-11:00 Samoa Standard Time Midway Is, Samoa

-10:00 Hawaiian Standard Time Hawaii

-10:00 Alaskan Standard Time Alaska

-08:00 Pacific Standard Time
Pacific Time (US & 
Canada); Tijuana

-07:00 Mountain Standard Time
Mountain Time (US & 
Canada)

-07:00
Mountain Standard Time 
[Arizona]

Arizona

-06:00 Central Standard Time
Central Time (US & 
Canada)

-06:00 Mexico Standard Time Mexico City, Tegucigalpa

-06:00
Canada Central Standard 
Time

Saskatchewan

-05:00 Eastern Standard Time
Eastern Time (US & 
Canada)

-05:00
Eastern Standard Time 
[Indiana (East)]

Indiana (East)

-05:00 SA Pacific Standard Time Bogota, Lima, Quito

-04:00 Atlantic Standard Time Atlantic Time (Canada)

-04:00 SA Western Standard Time Caracas, La Paz
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-03:30
Newfoundland Standard 
Time

Newfoundland

-03:00 SA Eastern Standard Time Buenos Aires, Georgetown

-03:00
E. South America Standard 
Time

Brasilia

-02:00 Mid-Atlantic Standard Time Mid-Atlantic

-01:00 Azores Standard Time Azores

00:00 Universal Coordinated Time Casablanca, Monrovia

00:00 Greenwich Mean Time
Greenwich Mean Time: 
Dublin, Edinburgh, Lisbon, 
London

+01:00 Romance Standard Time
Amsterdam, CopenHagen, 
Madrid, Paris, Vilnius

+01:00
Central European Standard 
Time

Belgrade, Sarajevo, Skopje, 
Sofija, Zagreb

+01:00
Central Europe Standard 
Time

Bratislava, Budapest, 
Ljubljana, Prague, Warsaw

+01:00 W. Europe Standard Time
Brussels, Berlin, Bern, 
Rome, Stockholm, Vienna

+02:00 Egypt Standard Time Cairo

+02:00 South Africa Standard Time Harare, Pretoria

+02:00 Israel Standard Time Israel

+02:00 E. Europe Standard Time Bucharest

+02:00 FLE Standard Time Helsinki, Riga, Tallinn

+02:00 GTB Standard Time Athens, Istanbul, Minsk

+03:00 Arab Standard Time Kuwait, Riyadh

+03:00 E. Africa Standard Time Nairobi

+03:00 Russian Standard Time
Moscow, St. Petersburg, 
Volgograd

+03:30 Iran Standard Time Tehran
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+04:00 Arabian Standard Time Abu Dhabi, Muscat

+04:00 Caucasus Standard Time Baku, Tbilisi

+04:00 Afghanistan Standard Time Kabul

+05:00 West Asia Standard Time
Islamabad, Karachi, 
Tashkent

+05:00 Ekaterinburg Standard Time Ekaterinburg

+05:30 India Standard Time
Bombay, Calcutta, Madras, 
New Delhi

+06:00 Central Asia Standard Time Almaty, Dhaka

+06:00 Sri Lanka Standard Time Columbo

+07:00 SE Asia Standard Time Bangkok, Hanoi, Jakarta

+08:00 China Standard Time
Beijing, Chongqing, Hong 
Kong, Urumqi

+08:00 W. Australia Standard Time Perth

+08:00 Singapore Standard Time Singapore

+08:00 Taipei Standard Time Taipei

+09:00 Tokyo Standard Time Osako, Sapporo, Tokyo

+09:00 Korea Standard Time Seoul

+09:00 Yakutsk Standard Time Yakutsk

+09:30 AUS Central Standard Time Darwin

+09:30
Cen. Australia Standard 
Time

Adelaide

+10:00 AUS Eastern Standard Time
Canberra, Melbourne, 
Sydney

+10:00 E. Australia Standard Time Brisbane

+10:00 West Pacific Standard Time Guam, Port Moresby

+10:00 Tasmania Standard Time Hobart

+10:00 Vladivostok Standard Time Vladivostok
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+11:00
Central Pacific Standard 
Time

Magadan, Solomon Is, New 
Caledonia

+12:00 Fiji Standard Time Fiji, Kamchatka, Marshall Is

+12:00 New Zealand Standard Time Auckland, Wellington

http://www.problemtracker.com/pthelp5/install/wms_tz_nt.htm (4 of 4) [3/3/2003 12:29:51 PM]



NetResults ProblemTracker Help

 NetResults ProblemTracker  

Frequently Asked Questions  

Our frequently asked questions section is updated quite often. For the latest information, available 24 hours a 
day, 7 days a week, please browse to the Frequently Asked Questions in the ProblemTracker Support section 
of our web site. It has answers to many questions that are asked by our customers. It is likely that you will find 
the answer to your question or resolution (or workaround) to a problem in the FAQ. 
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Contacting NetResults  

If you are unable to resolve a problem after searching the ProblemTracker Frequently Asked Questions section 
of our web site, and you are evaluating the product or have a current support agreement with NetResults, 
please contact us via email. Standard support is available via email on business days (Monday through Friday, 
excluding holidays). You should receive a response within one business day. Additional support options (e.g. 
phone support, extended hours) may be purchased from NetResults. Phone support is not included with the 
product, it must be purchased separately. 

For the appropriate support email address, standard support hours, and a list of information to send us for 
fastest resolution to your problem, please click here. If for some reason you are unable to reach our site via the 
web, please send your support email to 

pt_support@netresultscorp.com 

In your email please be sure to include the following information (emails with this information are generally 
given priority over those without): 

1.  Version of ProblemTracker you are using. 
2.  Web Server software being used (e.g. IIS 4, Netscape Enterprise 3.6). 
3.  Database being using (e.g. MS Access, MS SQL Server 7.0). 
4.  Operating System of the server on which ProblemTracker is installed (e.g. Windows NT 4.0 

Workstation, Windows NT 4.0 Server). 
5.  Web Browser software being used (e.g. IE 4, Navigator 4.0). 
6.  The full text of any error message which is displayed. In many cases if you get a generic database 

error message, you can scroll further down on the page to find more detailed error information. 
7.  The steps required to reproduce the problem. 
8.  Whether you are an evaluator or licensed user with support. 
9.  Attach the following files from your installation to your message:

❍     Any files present in the folder NetResultsPTLog that can be found in the root of the drive where 
you installed ProblemTracker. By default, the files can be found in C:\NetResultsPTLog. 

❍     If your problem is related to the Workgroup Management System, attach the file called 
ptadminlog.txt that can be found in the pttmp folder of your installation directory. By default, this 
file can be found at C:\Inetpub\wwwroot\ProblemTracker\pttmp\ptadminlog.txt. 

❍     If your problem is related to email notification messages, attach the file called emaillog.txt that 
can be found in the pttmp folder of your installation directory. By default, this file can be found at 
C:\Inetpub\wwwroot\ProblemTracker\pttmp\emaillog.txt. 

Please be as specific as possible in your description of what is wrong. Including steps to reproduce the problem 
and the full text of all error messages is very helpful and can significantly reduce the amount of time it takes to 
resolve a problem. 
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http://www.netresultscorp.com/pt_support.html
mailto:pt_support@netresultscorp.com
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